It is currently Fri Nov 24, 2017 11:16 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 30 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 7:02 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
Hi

I am using Portable Coollector V 3.25.9

Initially I added 665 movies as Owned and uploaded the backup and published it online.

Now, I have added a few more to that collection. However, if I upload and publish it now, I still see only the 665 movies list but not the latest one (about 722).

Am I doing something wrong?

Another question I have is, is it possible for me to delete my online backups? I have 2 backups created online and I want to delete the older one. Any chance I could do that myself?

I have noticed a few other bugs as well but they are not major bugs and I do not mind working around them for now.

Thanks


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 7:20 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
prasanna3k wrote:
Now, I have added a few more to that collection. However, if I upload and publish it now, I still see only the 665 movies list but not the latest one (about 722).

It looks like the upload has failed. Have you tried uploading again?


prasanna3k wrote:
I have 2 backups created online and I want to delete the older one. Any chance I could do that myself?

The program uploads to the server your last 10 backups. It's automatic. You can't change that, but I don't see how it could be a problem.


prasanna3k wrote:
I have noticed a few other bugs as well but they are not major bugs and I do not mind working around them for now.

When you'll have time, I'll appreciate if you help me fix those bugs. I won't sleep well until you tell me what those bugs are ;)


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 7:50 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
Hi

Not sure why the upload fails. After the upload process runs, I wait for a while and then it opens up my collection page on the browser.

However, the page is not updated and the number of backups on the server do not increase as well.

This is where I believe a feature to delete the backups might come in handy. Then, I could delete all existing backups and force a fresh upload to my account's backups.

I would try the uploads a few more times (tried it 4 times so far) to see if it fixes the issue.

One of the issues I noticed is that the program crashed several times initially. While I was trying to add more than 600 movies at once, it showed up the recognized list and while I was scrolling through it, and clicking on some movies to check the cast in the background window and verify if it is the right movie, the program crashed.

It was a tough time and after a few crashes, I dragged the error message window to the corner of my screen and continued my work.

Another issue is with the PLAY icon under each movie's poster. Clicking it once shows the directory path but selecting the directory path does not do anything. It would be great if the file could be opened in the system's default application for that movie format (e.g., VLC).

Also, when multiple movies match the title, the program picks up one (which may be incorrect). I do not have an option to force the program to show me all relevant movies and let me pick one. If the program scans and decides an incorrect movie, I have to exclude it from the list and then manually add the location.

When the program runs, if I select to Sort by title, the next time I launch it, it switches back to Sort by Popularity.

While searching for movies, there is an auto predict implementation but its implementation is not good. I would rather see this feature turned off. Also, the search results get stuck and sometimes do not get refreshed. I use Single pane layout and i have go back and choose movies there (in the 1st pane) instead of choosing from the search page (which is the 2nd pane).

I am not sure if I have explained the issues clearly. Please let me know if you need any more information.

Thanks for your quick response and I appreciate it. I would continue to report bugs if I experience any issues.

Cheers


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 8:21 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
prasanna3k wrote:
After the upload process runs, I wait for a while and then it opens up my collection page on the browser.

However, the page is not updated and the number of backups on the server do not increase as well.

Thank you for confirming that you have tried multiple time. My server logs indeed tell me that something goes wrong. If you have the time to collaborate with me on this issue, we could track this bug and fix it.


prasanna3k wrote:
This is where I believe a feature to delete the backups might come in handy. Then, I could delete all existing backups and force a fresh upload to my account's backups.

The backups already on the server can't be a problem. The program takes the 10 freshest backups from your computer, and uploads those that are not already on the server.


prasanna3k wrote:
I would try the uploads a few more times (tried it 4 times so far) to see if it fixes the issue.

It's not necessary. I can see that there's a problem that needs to be fixed.


prasanna3k wrote:
One of the issues I noticed is that the program crashed several times initially. While I was trying to add more than 600 movies at once, it showed up the recognized list and while I was scrolling through it, and clicking on some movies to check the cast in the background window and verify if it is the right movie, the program crashed.

Thank you, I will experiment to see if I can reproduce this bug.


prasanna3k wrote:
Another issue is with the PLAY icon under each movie's poster. Clicking it once shows the directory path but selecting the directory path does not do anything. It would be great if the file could be opened in the system's default application for that movie format (e.g., VLC).

If VLC is associated to the file extension, then the file will indeed be played by VLC. But from your message, I think you might make a confusion. When you haven't associated any video file, the play icon is ghosted like all the other icons, and clicking it will allow you to manually associate a file. Once there are files associated, the icon isn't ghosted anymore, and clicking it will allow you to play an associated file, or associate a new one.


prasanna3k wrote:
Also, when multiple movies match the title, the program picks up one (which may be incorrect). I do not have an option to force the program to show me all relevant movies and let me pick one. If the program scans and decides an incorrect movie, I have to exclude it from the list and then manually add the location.

Please give me some examples, but I suppose it's movies with same title but different years. You have the option to rename the file to include the year, and it should work. The last option is to associate the file manually by going to the movie and clicking the "play" icon.


prasanna3k wrote:
When the program runs, if I select to Sort by title, the next time I launch it, it switches back to Sort by Popularity.

The settings are remembered fine on my computer. I will test with the portable version to see if it's an issue with the portable version.


prasanna3k wrote:
While searching for movies, there is an auto predict implementation but its implementation is not good.

Please give me some examples to help me understand. You're talking about the string search, aren't you? Not the filtered search?


prasanna3k wrote:
I would rather see this feature turned off.

If you're talking about the string search word completion, it's completely impossible to remove it. That's how the search works. We're using indexing techniques to avoid checking the 107,000 titles each time you make a search. Without those optimizations, each search would take several seconds.


prasanna3k wrote:
Thanks for your quick response and I appreciate it. I would continue to report bugs if I experience any issues.

Thanks for your feedback!


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 8:39 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
Hi

Sorry that I am not quoting the appropriate sections, since the post is long.

I would wait for your update on the upload issue. Unfortunately, it isn't possible for me to help you out now in resolving this issue.

The play icon is not ghosted. It is blue. Clicking the icon gives me 2 options.
1. Associate a new video file to the movie
2. The path of the file that is currently associated. Clicking this should ideally launch the media player to play the file. However, in my case, this is not happening.

For multiple movies with the same name (released in different years), I understand the issue and the manual solution. However, what I would like to see is a pop up of some sorts if multiple matches are found, so that I can choose the right one. Including the year in the title, while it may work, I follow IMDB names as folder names and I cannot change the structure to include the year. At present, the only solution I see is to do this manually. You could put this feature down as an enhancement in future if possible.

Ignore my comment about the search feature. I was not hitting enter key after typing in the search string. I started looking at the search results before pressing the Enter key and wasn't satisfied with the search results. My mistake.

Thanks for taking your time in reading through my long messages.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 9:01 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
prasanna3k wrote:
I would wait for your update on the upload issue.

I can't do anything without your help. I have no idea what going wrong.


prasanna3k wrote:
Unfortunately, it isn't possible for me to help you out now in resolving this issue.

Then I'll wait until you have some time to help me. I'll build a version of the program that reports at each stage what's going on with the upload, and we'll be able to find the exact moment when the bug occurs.


prasanna3k wrote:
The play icon is not ghosted. It is blue.

Ok, I needed to make sure about that


prasanna3k wrote:
Clicking this should ideally launch the media player to play the file. However, in my case, this is not happening.

When you double click the exact same file from Windows Explorer, does it open with VLC? If that's the case, then I should be able to create another test program to understand the problem.


prasanna3k wrote:
For multiple movies with the same name (released in different years), I understand the issue and the manual solution. However, what I would like to see is a pop up of some sorts if multiple matches are found, so that I can choose the right one

Your idea is interesting. How would you change the interface to allow that? I'll appreciate your suggestions, because I have no clear idea how to do it, interface-wise.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 9:12 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
Hi

If you can give me the test programs now to figure out the issue with the uploads, I could send you the log files earliest by tomorrow.

The same files open in VLC, when I double click from Windows explorer. If the above test program can look into this issue as well, it would be great. I do not mind if you have to send me a separate program for this. Please go ahead with the easier option for you.

I would suggest that if multiple matches are found, switch them to a new tab. Currently there is a tab for Recognized and Not Recognized. Include another tab saying something like "Select Manually". In that, give each movie as a drop down and in the window, show the possible matches. Once a movie is selected and user clicks on confirm, you can remove that entry from the list of multiple matches, add it to the recognized ones and allow the user to go to the next movie in the drop down.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 9:20 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
Hi

Identified the issue with the file playback. I had reinstalled VLC which had removed the file associations for mkv format. Added it now and the program plays the files.

My sincere apologies for causing the confusion. Please ignore this particular issue.

Regards


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 9:27 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
prasanna3k wrote:
If you can give me the test programs now to figure out the issue with the uploads, I could send you the log files earliest by tomorrow.

I've had a long day, and I'm exhausted. I'm afraid I can't make the test program today, but if you're ok, I'll make it tomorrow.


prasanna3k wrote:
I would suggest that if multiple matches are found, switch them to a new tab. Currently there is a tab for Recognized and Not Recognized. Include another tab saying something like "Select Manually".

I hadn't thought about a new tab. At first, I did not like your idea, but in the end I think it could be a good solution. I don't think this improvement is a priority because the case happens rarely, and in most cases Coollector picks the right movie as it selects the most popular, but I add this improvement to my todo list.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 9:28 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
prasanna3k wrote:
Identified the issue with the file playback. I had reinstalled VLC which had removed the file associations for mkv format. Added it now and the program plays the files.

That's why I asked if it worked with the "exact same file" ;)


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Mon Jul 22, 2013 9:34 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
Sorry about that. Was trying mkv from Coollector and mp4 from Windows Explorer.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Tue Jul 23, 2013 12:49 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
(cool) Hector wrote:
I will test with the portable version to see if it's an issue with the portable version.

I've just tested the portable version, and I see no problem, the settings are remembered fine on my computer.

You need to know that the settings are saved at the moment you close the program, so if the program crashes, the settings won't be saved. Could you please make the test again and confirm that the settings aren't remembered, even after closing the program normally.

In the case of the portable version, the settings are written inside the file "Portable.txt". Please right click this file and select "properties" to check that the file is not "read-only". You could also make some tests to see if some settings are remembered while other settings aren't.

Thank you!


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Tue Jul 23, 2013 1:38 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
If your folder is read-only and the program can't write to it, it could explain why the settings are not remembered. It could also explain why uploading to the server doesn't work. Indeed, the program writes some files inside the folder "Tmp", and then uploads those files.

Before I make a test program to understand why the online backup doesn't work, please test that Coollector is able to write to the disk. The online backup has worked once, and now it doesn't work anymore. Maybe a folder has becomed read-only, or maybe you've moved the program to a new location where it doesn't have the permission to write.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Tue Jul 23, 2013 1:53 pm 
Offline

Joined: Thu Jul 18, 2013 8:51 pm
Posts: 13
I uploaded the backup sometime back from a faster network and it worked.

The folder structure and location is the same from when I tried to upload yesterday and it failed.


Top
 Profile  
 
 Post subject: Re: Help with online backup and Publish
PostPosted: Tue Jul 23, 2013 1:57 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
Have you checked if the file "Portable.txt" is ready only?

Sometimes it happens without you doing anything.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 30 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2017 phpBB Group