It is currently Tue Nov 21, 2017 10:02 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Thu Aug 15, 2013 11:59 pm 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
I seems I made a mistake about the ftp. It was aft all along. The WD NAS under discussion was and is aft. The Time Capsule is also aft.

Are you sure smb would be superior to aft? Would it certainly be worth the effort to change? Could you give me a hint why?


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 12:11 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
adamintelaviv wrote:
I seems I made a mistake about the ftp. It was aft all along. The WD NAS under discussion was and is aft. The Time Capsule is also aft.

AFT or AFP?


adamintelaviv wrote:
Are you sure smb would be superior to aft? Would it certainly be worth the effort to change? Could you give me a hint why?

AFP is an old Apple protocol. Samba is the de-facto standard protocol, used on Mac, Windows and Linux.

With Samba, Coollector would work, because Coollector is written with a library (wxWidgets) that can handle the standard Samba protocol, but can't handle the AFP protocol.

I'm 99.9% sure that your NAS will work at least as good as now, if you switch to Samba.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 12:22 am 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
I apologise. I keep getting it wrong. :( I wrote aft but the external disks are using afp.

There is no ftp. no aft.

There is only afp currently, and some smb in the history, apparently for connecting to Windows devices.

If I use the WD external disk's IP Address (10.0.1.5) I can, I think, get it to use smb. I am not sure if this make a difference, or if I can get it to keep using smb after restarting.

Should I keep working on switching to smb?


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 12:23 am 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
I see you responded as I was writing. Thanks.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 12:42 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
adamintelaviv wrote:
Should I keep working on switching to smb?
You decide :sorry:

Adding your video files one by one is a PITA, when you could conveniently scan them automatically.

Coollector will never work with AFP. Your only solution is to switch to Samba.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 12:57 am 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
PITA indeed!

I will keep working on it. I see that something called SMB2 will be the default in the next Apple OS. I will, eventually, get the benefit of smb even if i do not find a way until then.

http://reviews.cnet.com/8301-13727_7-57 ... etworking/


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 1:01 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
So what's the address of your NAS?

Here's what I found on the net:

Go to Finder. Click Go->Connect to Server...
Then type:
smb://<NAS address>/

I suppose it's an equivalent to Command + K. I don't understand why Command + K did not work. Maybe you made a mistake.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 1:43 am 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
Would 10.0.1.5 be the correct format for the NAS address? If not, how would i find my NAS address.

It seems to work, smb with 10.0.1.5. The thing is that it will not remain the default after a restart.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 2:27 am 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
I got it to work with the IP Address. In smb it scanned the folder perfectly and added 15 video files like a dream. :yahoo:

Even if it does not remain as default, I can certainly use it when adding video files as owned.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 9:25 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
adamintelaviv wrote:
It has a "Network Mode" setting with a choice between "DHCP" and "Static". I am using DHCP.

...

It seems to work, smb with 10.0.1.5. The thing is that it will not remain the default after a restart.

Instead of "DHCP" (dynamic address), use "static", and the NAS will keep the same address ;)


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 9:26 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
adamintelaviv wrote:
In smb it scanned the folder perfectly and added 15 video files like a dream. :yahoo:

I felt your pain when you had to add the files one by one :yes:


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 9:42 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
adamintelaviv wrote:
I got it to work with the IP Address. In smb it scanned the folder perfectly and added 15 video files like a dream. :yahoo:

If I'm correct, we've now fixed all your problems, haven't we?


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 9:43 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
Please try playing the files that you've just scanned. I have a hunch that they'll play fine.


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Fri Aug 16, 2013 10:09 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5862
adamintelaviv wrote:
Would 10.0.1.5 be the correct format for the NAS address?

Your NAS has probably a name that you could use instead of the IP address.

The address of my NAS is "smb://dlink-df5dcf"


Top
 Profile  
 
 Post subject: Re: Crash when adding video file as ownedafter update to v3.
PostPosted: Sat Aug 17, 2013 1:52 am 
Offline

Joined: Sun Aug 11, 2013 4:34 pm
Posts: 23
You certainly solved my problem in the sense that when I connect to my NAS using SMB, Coollector works like a dream including playing videos.

Coollector is even better than I realised now that it is set up correctly :clap:

The problem is that AFP seems to be the default, and I have not figured out how to change it for my NAS.

This is clear very far from being your problem, so your help is very much appreciated.

I am in good shape, I can switch manually to smb at will.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 48 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2017 phpBB Group