It is currently Sat Nov 25, 2017 5:39 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Bug
PostPosted: Thu Mar 09, 2017 11:12 am 
Offline

Joined: Thu Nov 17, 2016 2:14 am
Posts: 64
When i perform a 'scan your files' and the LAST scan location was a UNC path to now unavailable storage the program hangs.

In my case the above was to a linux fileserver that is offline. I presume you save this location and try to populate a directory list before the scan.


Thanks in advance

Edit .... I've noticed it does eventually time out but this takes minutes.


Top
 Profile  
 
 Post subject: Re: Bug
PostPosted: Thu Mar 09, 2017 3:46 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
beldeamon wrote:
I presume you save this location

Yes.


beldeamon wrote:
and try to populate a directory list before the scan.

I don't populate anything, I just ask Windows to display a folder selection dialog. This dialog is native to Windows and completely managed by Windows. I've noticed that this dialog can be randomly capricious and take a long time to load, but I'm afraid there's nothing I can do about it. When I open the Windows' Task Manager, sometimes I can see that my disk access is at 100% and that's when this kind of waiting happens.


beldeamon wrote:
I've noticed it does eventually time out but this takes minutes

Are you ok now?


Top
 Profile  
 
 Post subject: Re: Bug
PostPosted: Thu Mar 09, 2017 8:54 pm 
Offline

Joined: Thu Nov 17, 2016 2:14 am
Posts: 64
Sorry for late reply .... but posted this morning before work

Working fine now and fully understand why it occurs :)

I wasnt sure if you were aware of this and if you could circumvent or not .... Like you say, at the end of the day its a windows dialog you are call .. If i type the address \\192.xx.xx.xx in an explorer window i see the same, about minute or two later it comes back and says it cannot find.

Thanks for the usual swift reply, chalk this one down MS i think :)


Top
 Profile  
 
 Post subject: Re: Bug
PostPosted: Thu Mar 09, 2017 9:01 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
beldeamon wrote:
If i type the address \\192.xx.xx.xx in an explorer window i see the same, about minute or two later it comes back and says it cannot find.

I've made the test and indeed there's a long delay when the location doesn't exist anymore.

With the next version, I'll check if the location exists or not, and pass the dialog an empty value if it doesn't.

;)


Top
 Profile  
 
 Post subject: Re: Bug
PostPosted: Fri Mar 10, 2017 10:44 am 
Offline

Joined: Thu Nov 17, 2016 2:14 am
Posts: 64
:V: Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2017 phpBB Group