It is currently Thu May 24, 2018 5:34 pm

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Sun Oct 22, 2017 7:32 pm 
Offline
User avatar

Joined: Fri Jul 27, 2012 1:24 pm
Posts: 131
Location: India
Sometimes I got these two simultanious error. I tried to replicate the error again but I am unsuccessful. :cry:

Attachment:
error.JPG
error.JPG [ 91.99 KiB | Viewed 876 times ]


Attachment:
Screenshot (169).png
Screenshot (169).png [ 189.29 KiB | Viewed 876 times ]

_________________
- Abubakar Siddique
1361th Coollector Forum User :yahoo: :yahoo:
Youtube: www.youtube.com/IOGuru
Play Store: [COMING_SOON]


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Mon Oct 23, 2017 11:56 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
Thank you for reporting this bug. I'm surprised that you can't replicate it.

Does it happen with this skin only? Is Coollector minimized or full screen?


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Mon Oct 23, 2017 1:52 pm 
Offline
User avatar

Joined: Fri Jul 27, 2012 1:24 pm
Posts: 131
Location: India
(cool) Hector wrote:
Thank you for reporting this bug. I'm surprised that you can't replicate it.

Does it happen with this skin only?


Well I guess it happens with other skin too because this is a very new skin which I created yesterday night. And the error used to occur even before too (but maybe while after modifying skins and navigate through the tabs to see the final work of skin - I am not sure though).

Quote:
Is Coollector minimized or full screen?

My Coollector was maximized

_________________
- Abubakar Siddique
1361th Coollector Forum User :yahoo: :yahoo:
Youtube: www.youtube.com/IOGuru
Play Store: [COMING_SOON]


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Mon Oct 23, 2017 2:16 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
Abubakar Siddique wrote:
My Coollector was maximized

I'm even more surprised that the bug isn't reproductible :worried:


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Wed Jan 10, 2018 11:59 am 
Offline
User avatar

Joined: Tue Jul 05, 2011 12:15 pm
Posts: 70
---------------------------
wxWidgets Debug Alert
---------------------------
..\..\src\common\object.cpp(353): assert "m_count > 0" failed in wxRefCounter::DecRef(): invalid ref data count [in thread ce8]
Do you want to stop the program?
You can also choose [Cancel] to suppress further warnings.
---------------------------
Yes No Cancel
---------------------------

hi, when i add "images" folder to this location ---> documents\coollector\
the program has bug.
i dont add anything like skin or my coollection.cool .
before of add that folder the program is run correctly right.
i do this before and dont have any problem.
ver Coollector 4.9.9.9
thanks


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Wed Jan 10, 2018 12:18 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
salat_1364 wrote:
when i add "images" folder to this location ---> documents\coollector\
the program has bug.

I don't understand what you are doing... Why do you add an "images" folder? What does it contain? How can it interfere with Coollector?


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Thu Jan 11, 2018 3:15 pm 
Offline
User avatar

Joined: Tue Jul 05, 2011 12:15 pm
Posts: 70
(cool) Hector wrote:
salat_1364 wrote:
when i add "images" folder to this location ---> documents\coollector\
the program has bug.

I don't understand what you are doing... Why do you add an "images" folder? What does it contain? How can it interfere with Coollector?


because i install new windows and i want add images folder to see all pictures before i download.


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Thu Jan 11, 2018 4:07 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
salat_1364 wrote:
i install new windows and i want add images folder to see all pictures before i download.

Ok, I think I understand now.

About the error message, there's been a couple of users reporting the same issue, and I'm working on a fix. When it's ready, I'll ask you to try it.


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Thu Jan 11, 2018 5:51 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
Please test this version and tell me what you get:

http://www.coollector.com/Coollector_Test.exe

It's kind of a proof of concept. It has a couple of defects that I'll fix tomorrow (I'm going out tonight), but at least it should never crash. Does it crash on you?


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Fri Jan 12, 2018 6:24 pm 
Offline
User avatar

Joined: Tue Jul 05, 2011 12:15 pm
Posts: 70
(cool) Hector wrote:
Please test this version and tell me what you get:

http://www.coollector.com/Coollector_Test.exe

It's kind of a proof of concept. It has a couple of defects that I'll fix tomorrow (I'm going out tonight), but at least it should never crash. Does it crash on you?


well done, When I'm connected to the Internet it works well
But when I cut off the Internet, I'll send the error message again.
Hope to help


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Fri Jan 12, 2018 7:54 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
salat_1364 wrote:
When I'm connected to the Internet it works well
But when I cut off the Internet, I'll send the error message again.

Thank you for the feedback, I'm preparing a better version.


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Sat Jan 13, 2018 2:47 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
I thought I had found the solution, but I've discovered that the issue is even more complex.

I have to try something else. I'll give you a working version as soon as possible.


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Sat Jan 13, 2018 12:22 pm 
Offline
User avatar

Joined: Tue Jul 05, 2011 12:15 pm
Posts: 70
(cool) Hector wrote:
I thought I had found the solution, but I've discovered that the issue is even more complex.

I have to try something else. I'll give you a working version as soon as possible.

thank you for your attention


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Sat Jan 13, 2018 3:42 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
Really nasty bug. It makes me sweat :worried:


Top
 Profile  
 
 Post subject: Re: wxWidgets Debug Alert - getSubBitmap error
PostPosted: Sun Jan 14, 2018 1:56 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 6102
I'm sorry it's taking me so long.

You can download the previous version here:

37.59.40.189/Coollector4998_Setup.exe


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2018 phpBB Group