It is currently Sat Nov 25, 2017 5:50 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Failed to Open URL
PostPosted: Tue Mar 20, 2012 12:33 am 
Offline
User avatar

Joined: Sat Feb 04, 2012 3:07 pm
Posts: 63
I changed my default browser today, and whenever I clicked a link on Coollector to open up a web page, it always comes up with Failed to open URL error 2147221003.

I then made my original browser the default again, yet continue to get the same error.

I have changed my default browser in the past and there has never been an issue like this until today.
Nothing has been moved, installed or uninstalled. The only change has been the Coollector database update today, but I cant see how that should change something like this.


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Tue Mar 20, 2012 12:46 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
Have you restarted your computer ? Have you tried uninstalling and re-installing the browser ?


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 21, 2012 4:06 pm 
Offline
User avatar

Joined: Sat Feb 04, 2012 3:07 pm
Posts: 63
Yes I've restarted and Yes, I've reinstalled the brower, but I still get the same error..

I cant see how changing the default browser should affect anything, and I've done it before without any problems.

The only thing I can think of is to reinstall Coollector, which I'm about to do now.


Edit - I uninstalled Coollector. There were some registry entries remaining. Something along the lines of cool auto file. I removed these, and the downloaded the portable version of Coollector.

I am still having the same issue, except now the error message is different. No application associated whenever I click a link.


Attachments:
Error.jpg
Error.jpg [ 24.94 KiB | Viewed 2335 times ]
Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 21, 2012 6:06 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
I don't think it's a problem with Coollector (I haven't changed anything).

When you receive a mail (in Outlook, or Thunderbird, or whatever), and that mail has a link, and you click that link, does it open fine in your web browser ?


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 21, 2012 8:36 pm 
Offline
User avatar

Joined: Sat Feb 04, 2012 3:07 pm
Posts: 63
Yes, it works fine.

I don't have browser/opening link problems in any other applications. My system is working the same as it always has.

This is only happening with Coollector recently, which is why I cant work out whats wrong.

Uninstalling/Reinstalling both Coollector and multiple browsers have had no change on things whatsoever. It's strange.


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 21, 2012 8:49 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
I don't have the beginning of an explanation. :(


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 21, 2012 9:03 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
Here is the version 3.19.8:

http://www.coollector.com/Coollector3198_Setup.exe

If you want to try it.


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Thu Mar 22, 2012 2:19 pm 
Offline
User avatar

Joined: Sat Feb 04, 2012 3:07 pm
Posts: 63
Ok, I tried that version and I get a different error now.

Now it's saying the error occurs while sending the command to the browser. There's definitely nothing wrong with my browsers as everything else is working fine.

I really dont know whats going on, but its only happening with Coollector. Could it be a corrupt registry entry?


Attachments:
Error 2.jpg
Error 2.jpg [ 23.15 KiB | Viewed 2317 times ]
Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Thu Mar 22, 2012 4:16 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
Skimadikal wrote:
Could it be a corrupt registry entry?

I have no idea. I'm just using the wxWidgets function wxLaunchDefaultBrowser(). Don't know what can go wrong :worried:

What version of Windows are you using ?


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 28, 2012 3:33 am 
Offline
User avatar

Joined: Sat Feb 04, 2012 3:07 pm
Posts: 63
I'm using Win7 Ultimate (64 bit)

The thing is, it WAS working before. I have tried clean reinstallations of browsers and coollector yet again since the last time, but nothing seems to fix these errors.

I'm all out of ideas, and I dont want to do a clean install of the OS, as everything else on my pc is running just fine.

It was when I changed the default browser after an update that this started, yet I had done that before without a problem. wxLaunchDefaultBrowser should be working as we can only have one default browser.

I know that there was a bug launching mozilla on an older version of Wxwidgets that reproduced a similar error message, but Im assuming you would be using a new version, so I really can't think of what's gone wrong.


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Wed Mar 28, 2012 11:29 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
Skimadikal wrote:
I know that there was a bug launching mozilla on an older version of Wxwidgets that reproduced a similar error message, but Im assuming you would be using a new version, so I really can't think of what's gone wrong.

The revision of wxWidgets that I'm using is about 6 months old. I'll move to the latest version in a few weeks, and we'll see if that helps. I'm sorry that I don't do it sooner, but I'm too busy working on the new skin system.


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Fri Dec 07, 2012 12:03 am 
Offline

Joined: Thu Dec 06, 2012 11:48 pm
Posts: 19
Dont know if this is the right place to post just dont want to start another topic. I just installed your application coollector on my dell inspiron with windows vista. I have not purchased a key as yet but plan to as soon as I get some of the bugs resolved. My main concern is that I am unable to connect to your url in the help menu as I always get an unable to connect error message error 1155. Any help would be appreceated.

Regards Ron


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Fri Dec 07, 2012 12:18 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
freewave wrote:
as soon as I get some of the bugs resolved.

You are welcome to report all the bugs that you can find, it's much appreciated.


freewave wrote:
My main concern is that I am unable to connect to your url in the help menu as I always get an unable to connect error message error 1155

Are you on Mac or PC ?

Do you have the latest version 3.23.5 ?

Does the program download the pictures normally ?

Have you tried with your firewall and your antivirus disabled ?


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Fri Dec 07, 2012 6:23 am 
Offline

Joined: Thu Dec 06, 2012 11:48 pm
Posts: 19
I am on a PC with the lattest version and pictures seem to be normal. I am using explorer9 and no I have not tried disabling my firewall or AVG free anti virus software.


Top
 Profile  
 
 Post subject: Re: Failed to Open URL
PostPosted: Fri Dec 07, 2012 7:03 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
I made a search, and if I'm right, error 1155 means "No application is associated with the specified file for this operation".

So ok, you have Internet Explorer 9 installed, but are you sure it is set as your default browser ?

Please try to adjust your Internet Explorer 9 settings. Maybe uninstalling and reinstalling Internet Explorer 9 would help. Maybe you could try installing another browser, and set it as your default browser.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2017 phpBB Group