It is currently Sat Nov 25, 2017 5:32 am

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: data base updates
PostPosted: Tue Apr 17, 2012 3:50 pm 
Offline

Joined: Tue Apr 17, 2012 3:41 pm
Posts: 4
I have tried to update the data base 3 times. The download is ok, but a report is generated as being unable to open the files, error code 13. I am running the programme on an iMac using Lion.
Any help would be appreciated.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Tue Apr 17, 2012 4:32 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
What version of Coollector are you using ? Have the updates worked before ?

We have several update servers. I have re-uploaded the files to all the servers, in case that one of them had a problem. Please give it another try.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Tue Apr 17, 2012 7:57 pm 
Offline

Joined: Tue Apr 17, 2012 3:41 pm
Posts: 4
Hi, I'm using version 3.20.9 The error message reads: Can't open file'?Applications/Coollector Movie Database.app/Contents/Resources//english.movies.dat' (error 13: Permission denied)
I acquired the prog. this week from Apple Apps. I am still in the process of entering my dvds'
I also got a (failed in GetSubBitmap0; So far, the programme crashes after about 20 entries being
entered. I am currently up to 500+ entries with a few to go, I assume that there is't a limit?
Regards


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Tue Apr 17, 2012 11:25 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
moxo00 wrote:
I acquired the prog. this week from Apple Apps.

Thanks for the information. The update process is different with the Mac App Store. I'll make some testing.


moxo00 wrote:
I also got a (failed in GetSubBitmap0; So far, the programme crashes after about 20 entries being entered.

I'm very surprised by your bad experience. I'll try to reproduce those bugs on my computer.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Wed Apr 18, 2012 12:07 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
moxo00 wrote:
failed in GetSubBitmap0

At what moment do you get that message ? When you browse the database ? Or only when you add a video ?


moxo00 wrote:
So far, the programme crashes after about 20 entries being
entered.

What method do you use to enter your videos ? Do you make a barcode search ? Do you click the "ADD" button ? Do you add from an existing video ?

At what moment does it crash ? Is it immediatly after you click the "add as owned" button ?

And when you launch the program again, was your entry saved ? Or is it lost ?


moxo00 wrote:
I am currently up to 500+ entries with a few to go, I assume that there is't a limit?

No limits of course. We have users with thousands of videos.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Wed Apr 18, 2012 1:10 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
moxo00 wrote:
So far, the programme crashes after about 20 entries being
entered.

Is it possible that you are suffering from this bug ?

http://www.coollector.com/viewtopic.php?f=2&t=895

Does it happen when you click while the video is not highlighted, and it doesn't crash if you make sure that it is highlighted ?

I have fixed this bug and the fix will be included with the next version of the program.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Wed Apr 18, 2012 6:58 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
moxo00 wrote:
The download is ok, but a report is generated as being unable to open the files, error code 13. I am running the programme on an iMac using Lion.

Indeed, I've been able to reproduce this bug by using a guest account on Lion.

It's the only case where this bug happens. This bug doesn't happen with an admin account, and it doesn't happen on Snow Leopard even with a guest account.

Please log in as administrator and tell me if the update goes fine.

I will modify the update process to work even with a guest account on Lion.

Thank you very much for your feedback !


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Wed Apr 18, 2012 7:04 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
Please help me to reproduce the other bugs, and I'll release a new version as soon as possible.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Wed Apr 18, 2012 10:39 pm 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
I have re-submitted the version 3.21.1 to the Mac App Store, to include all the bug fixes (except the GetSubBitmap0 error which I can't reproduce).

It's now one week that the status of 3.21.1 is "waiting for review". Hopefully it'll be reviewed and added soon.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Fri Apr 20, 2012 10:39 am 
Offline

Joined: Tue Apr 17, 2012 3:41 pm
Posts: 4
My entry method is...type into search. select correct item. add as owned. close.
I have just added 8 entries and experienced a crash. This generated a crash report. The key phrases seem to be: EXC_BAD_ACCESS(SIGSEGV) and
KERN_INVALID_ADDRESS.
When I first opened the prog today, I clicked on 'Update'. Some 52K enties were downloaded, then error 13 was noted and the database failed to update.
I trust that this answers some of your queries.
Regards


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Fri Apr 20, 2012 11:25 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
moxo00 wrote:
My entry method is...type into search. select correct item.

When you do that, does it happen that you only use the keyboard and don't have to move the mouse ? Your mouse is still above the "add" button and you click it ? In that case, the "add" button isn't greyed as it should be, and the program will crash later. It's a bug that I've fixed, I'm just waiting for Apple to add the new version on the App Store.


moxo00 wrote:
The key phrases seem to be: EXC_BAD_ACCESS(SIGSEGV) and
KERN_INVALID_ADDRESS.

Sorry, that's not enough information.

moxo00 wrote:
enties were downloaded, then error 13 was noted and the database failed to update.

You're not using an admin account, are you ? If so, that's also a bug that I've fixed.

About the GetSubBitmap0 error, does it happen often ? And what are you doing when it happens ?


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Tue Apr 24, 2012 10:53 am 
Offline

Joined: Tue Apr 17, 2012 3:41 pm
Posts: 4
Hi, I have just changed the preferences on the .dat file. The programme updated properly. I think that I have been entering data faster than the programme could process, hence the lock up.
So at the moment, all seems to be well. Thank you for your assistance.
Regards.


Top
 Profile  
 
 Post subject: Re: data base updates
PostPosted: Tue Apr 24, 2012 11:37 am 
Offline
User avatar

Joined: Tue Sep 27, 2005 2:28 am
Posts: 5863
moxo00 wrote:
I think that I have been entering data faster than the programme could process, hence the lock up.

I don't think it's possible to enter data too fast. Can't be the explanation :?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2017 phpBB Group